RUSTSEC-2019-0006

Buffer overflow and format vulnerabilities in functions exposed without unsafe

Issued
Package
ncurses (crates.io)
Type
Vulnerability
Aliases
Details
https://github.com/RustSec/advisory-db/issues/106
Patched
no patched versions
Affected Functions
Version
ncurses::instr
  • >=0.0.0
ncurses::mvprintw
  • >=0.0.0
ncurses::mvwinstr
  • >=0.0.0
ncurses::mvwprintw
  • >=0.0.0
ncurses::printw
  • >=0.0.0

Description

ncurses exposes functions from the ncurses library which:

More